Martes, Septiembre 25, 2018

Lazy FP: nueva vulnerabilidad que afecta a procesadores Intel

procesador-vulnerabilidad-intel

Los procesadores de Intel y AMD se han visto afectados en esta mitad de año por más de una decena de vulnerabilidades, algunas de ellas gravísimas y muy relacionadas entre sí, y que permitían acceder al contenido de la memoria en una zona que debería ser segura. A pesar de los parches, estos chips siguen teniendo otras vulnerabilidades, como la última descubierta para Intel llamada Lazy FP.

Lazy FP: permite conocer áreas de la memoria que deberían estar ocultas

Sobre la vulnerabilidad no se conocen demasiados detalles para no dar pistas a posibles atacantes, pero Red Hat ha revelado algunos datos sobre el problema. De entrada, afirman que este fallo sólo afecta a procesadores de Intel, y que no afectan a los de AMD. Además, por suerte, el fallo no afecta a nivel de hardware, sino que está ligado al software.

Esto permitirá parchearlo simplemente con una actualización del sistema operativo con Windows, o en el caso de Linux también a nivel de kernel. Tanto Microsoft como Apple están trabajando en un parche que arregle la vulnerabilidad, y lo lanzarán lo antes posible. Intel no ha revelado el impacto de la vulnerabilidad, pero afirman que su gravedad es “moderada”.

Según Intel ha descrito el problema, un atacante puede inferir mediante un proceso del sistema los datos que hay en otro proceso y realizar una ejecución especulativa, de tal manera que pueda conocer datos sensibles que en principio deberían estar ocultos ya que normalmente van cifrados. Dejar en texto plano algo que va cifrado suele ser uno de los objetivos más populares de los atacantes, ya que pueden sacarle un mayor rédito si obtienen datos como contraseñas.

La vulnerabilidad es muy similar a Spectre, y afecta a todos los procesadores de Intel lanzados en los últimos 7 años

Esta vulnerabilidad, como ya habréis deducido, es muy similar a Spectre, la cual ya tiene hasta cuatro variantes más. Por suerte, no requiere realizar cambios en el microcódigo. Los procesadores afectados van desde Sandy Bridge (Segunda generación de Intel Core, con chips como el i5-2500K) hasta los más actuales. Por ello, todos los ordenadores de los últimos 7 años que utilicen procesadores de Intel están afectados, por lo que tenéis que estar atentos para aplicar el parche lo antes posible.

Como vemos, todos los procesadores de Intel siguen teniendo un nivel mayor o menor de vulnerabilidad relacionado con Meltdown y Spectre, y por mucho que se vayan parcheando siguen apareciendo nuevos totalmente relacionados. Según afirmó Intel, la próxima generación de procesadores que lancen al mercado deberían tener arreglados estos problemas a nivel de hardware, por lo que serían seguros y no requerirían parches que pudieran afectar negativamente a su rendimiento.

 

Fuente: Softpedia | adslzone

¿Quién está en línea?

Hay 110 invitados y ningún miembro en línea

Contador de Visitas

12200763
Hoy Hoy 598
Ayer Ayer 1182
Esta semana Esta semana 1780
Este mes Este mes 33037
Total de Visitas Total de Visitas 12200763

Día con más
visitantes

09-14-2018 : 1609

Gracias por su visita