Sábado, Septiembre 21, 2019

Los procesadores Intel, hasta un 20% más lentos tras la enésima vulnerabilidad

intel-procesador-vulnerabilidad-zombieload

Ayer se desveló la enésima vulnerabilidad que afecta a procesadores Intel, las cuales han sido bautizadas como Microarchitectural Data Sampling (MDS), o llamada más coloquialmente como ZombieLoad. Además, se ha confirmado otro de los temores: su parche afecta negativamente al rendimiento, perdiendo hasta un 20%.

Casi todos los procesadores de Intel lanzados en los últimos 8 años, afectados por ZombieLoad

Entre los procesadores afectados encontramos los Intel Xeon, Broadwell, Sandy Bridge, Skylake, Haswell, Kaby Lake, Coffee Lake, Whiskey Lake, y Cascade Lake, además de todos los Atom y Knights. Básicamente, todos los procesadores lanzados después de 2011 son vulnerables.

ZombieLoad se aprovecha de un proceso de ejecución especulativa de manera similar aMeltdown y Spectre. Este tipo de ejecución mejora el rendimiento del procesador a través de intentar predecir qué va a hacer una aplicación o un sistema operativo, de manera que procesa los datos con antelación para tener el resultado ya listo. Gracias a esto, es posible acceder a información sensible como contraseñas, mensajes, tokens de acceso a servicios, etc. Es posible además que un malware, ejecutado en un proceso aislado, pueda acceder a información de otros procesos.

Las cuatro vulnerabilidades relacionadas con ZombieLoad son:

  • CVE-2018-12126: Microarchitectural Store Buffer Data Sampling (MSBDS)
  • CVE-2018-12130: Microarchitectural Fill Buffer Data Sampling (MFBDS)
  • CVE-2018-12127: Microarchitectural Load Port Data Sampling (MLPDS)
  • CVE-2019-11091: Microarchitectural Data Sampling Uncacheable Memory (MDSUM)

Las principales compañías, como Apple, Microsoft y Google, han lanzado en las últimas horas parches para solucionar todas estas vulnerabilidades. El problema es que el rendimiento se verá afectado tras aplicar este parche, de la misma manera que ocurrió cuando fue parcheado Meltdown. AMD, por su parte, dice que sus procesadores no están afectados por este ataque gracias a las comprobaciones y protecciones que tienen a nivel de hardware.

El rendimiento se ve afectado hasta un 19% en procesadores de consumo

Tampoco están afectados los chips ARM, ni tampoco se ha detectado ningún ataque a nivel global que haya aprovechado esta vulnerabilidad, aunque los descubridores afirman que la vulnerabilidad no deja rastro. Un atacante puede aprovecharse de esta vulnerabilidad simplemente ejecutando el código en una página web, haciendo que navegadores como Tor Browser sean inútiles, ya los datos se filtran entre procesos.

El parche que ya está aplicándose de estos procesadores afecta hasta un 19% el rendimiento para los procesadores de consumo, y hasta un 9% para los servidores, según ha anunciado la propia Intel. Los procesadores lanzados este año ya están protegidos ante este fallo, pero todos los anteriores lanzados de la 8ª generación hasta 2011 rendirán menos a partir de ahora.

El parche lo que hace es eliminar todos los datos del buffer cuando se supera un límite de seguridad, de tal manera que los datos no puedan ser robados. Intel afirma que el parche ya soluciona todos los problemas, pero los investigadores de seguridad han llegado a recomendar que se desactive el HyperThreading. Por suerte, no hay que llegar a esos extremos, ya que el rendimiento para ejecuciones en paralelo se vería gravemente afectado.

 

Fuente: Reuters | maslinux

¿Quién está en línea?

Hay 47 invitados y ningún miembro en línea

Contador de Visitas

12499207
Hoy Hoy 98
Ayer Ayer 811
Esta semana Esta semana 4396
Este mes Este mes 15744
Total de Visitas Total de Visitas 12499207

Día con más
visitantes

07-09-2019 : 3140

Gracias por su visita